QuickBooks Desktop 2021 Expiration Notice
Incident Report for R360 CLOUD HOSTING | RECUR360.com
Resolved
This incident has been resolved.
Posted May 13, 2024 - 13:18 PDT
Monitoring
Intuit has been pushing out pop ups about QuickBooks Desktop 2021 expiring at the end of May 2024. You can disregard this notice because our servers are on QuickBooks Desktop 2022-2024. If you are on a shared or dedicated server that isn't on QuickBooks Desktop 2024, you can request that we upgrade your server to QuickBooks Desktop 2024 or move you to a server with that version on it. You DO NOT need to migrate to QuickBooks Online. You can continue to use QuickBooks Desktop on our Remote Desktop servers for the foreseeable future.

Please come to https://r360.com and get on our LiveChat if you have any questions.
Posted May 13, 2024 - 10:04 PDT
This incident affected: R360 CLOUD HOSTING - QuickBooks Remote Desktops and RECUR360 Platform (RECUR360 - QuickBooks Online, RECUR360 - QuickBooks Desktop / Web Connector, RECUR360PAY/Merchant Track).