Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Sep 01, 2023 - 17:00 PDT
Update
We will be undergoing scheduled maintenance during this time.
Posted Aug 31, 2023 - 11:19 PDT
Scheduled
Dear R360 Cloud Hosting Customers,
In observance of the Labor Day Holiday weekend, our general support will be unavailable from Friday 9/1/2023 at 5 PM PDT through Tuesday 9/5/2023 at 5 AM PDT. We will only be available for server reboots. If users are traveling this weekend, you should verify you are able to remote in before Friday as you might not be able to remote into our servers over mobile cellular hot spots. Only broadband internet will connect to the servers. If you do anticipate working over the holiday, needing a password reset or will be getting a new mobile phone and therefore need your MFA reconfigured, please verify your access or come to our LiveChat at https://r360.com prior to 5 PM PDT on Friday.