R360 Hosting - Current Outage
Incident Report for R360 CLOUD HOSTING | RECUR360.com
Resolved
We found that there were internet interruptions at our data center this morning that was causing issues with push notifications and log in issues to the server. We have resolved the issues and customers can now log back on the servers. We appreciate the patience and apologize for the inconvenience.

Thanks.

R360 Hosting Staff
Posted Sep 23, 2024 - 11:12 PDT
Investigating
R360 Hosting Customers,

We are currently investigating an outage for hosting servers. We are looking into the issue and will let you know as soon as we have resolved, and you can log back in.

Thanks your for patience.

R360 Hosting Team
Posted Sep 23, 2024 - 09:18 PDT
This incident affected: R360 CLOUD HOSTING - QuickBooks Remote Desktops.