Livechat Issues

Incident Report for R360 CLOUD HOSTING | RECUR360.com

Resolved

LiveChat has fixed their issue and everything is working as normal now. You can come to our website www.r360.com for any LiveChat support. Thanks!!
Posted Feb 10, 2026 - 10:17 PST

Update

We are continuing to investigate this issue.
Posted Feb 10, 2026 - 10:15 PST

Investigating

LiveChat is currently having an issue with messages from us not showing up for the users to view. They have identified the issue and are implementing a fix now. We will update you again when LiveChat is working as normal.

If you are in need of Support please email Support@r360.com and we will reply to you immediately. Thanks!!
Posted Feb 10, 2026 - 09:51 PST
This incident affected: R360 CLOUD HOSTING - QuickBooks Remote Desktops.