Latest QB Update Fails to open

Incident Report for R360 CLOUD HOSTING | RECUR360.com

Resolved

The rollback of the update and server reboot has appeared to fix the login issue for QB files. Thank you again for your patience.

Andrew
Posted Aug 19, 2025 - 05:33 PDT

Monitoring

The latest QB update that came out over the weekend has been causing issues with opening a QB file. We implemented a fix yesterday that turned out to be only temporary. We have just rolled back the latest updates and rebooted servers. This should take care of this issue for good. Thank you for your patience.

Andrew
Posted Aug 19, 2025 - 05:10 PDT
This incident affected: R360 CLOUD HOSTING - QuickBooks Remote Desktops.