R360 QuickBooks Remote Desktop Cloud Hosting Update
Incident Report for R360 CLOUD HOSTING | RECUR360.com
Resolved
This incident has been resolved.
Posted Jan 13, 2023 - 12:20 PST
Update
Dear R360 QuickBooks Remote Desktop Cloud Hosting Customers,

Happy New Year!

We've made a recent change to our websites. Please make sure you are using https://r360.com to Login for your QuickBooks Remote Desktop Cloud Hosting.

If you need assistance, please come to https://r360.com and click on the Chat window for Support.

Have a Happy and Healthy New Year.

R360 QUickBooks Remote Desktop Cloud Hosting Support
Posted Jan 03, 2023 - 07:55 PST
Monitoring
Dear R360 QuickBooks Remote Desktop Cloud Hosting Customers,

Happy New Year!

We've made a recent change to our websites. Please make sure you are using https://r360.com to Login for your QuickBooks Remote Desktop Cloud Hosting.

If you need assistance, please come to https://r360.com and click on the Chat window for Support.

Have a Happy and Healthy New Year.

R360 QUickBooks Remote Desktop Cloud Hosting Support
Posted Dec 30, 2022 - 09:29 PST
This incident affected: R360 CLOUD HOSTING - QuickBooks Remote Desktops.