LiveChat Issues

Incident Report for R360 CLOUD HOSTING | RECUR360.com

Resolved

Livechat has deployed a fix and chats should be working as normal. If you still are having nay issue with starting a livechat and need support please email us at Support@r360.com

Thanks!!
Andrew
Posted Feb 25, 2026 - 10:49 PST

Monitoring

Livechat is having issues with chats not starting properly. They are working on the issue and hope to have it fixed shortly. In the meantime please send all all support issues to our email at support@r360.com Thanks!!
Posted Feb 25, 2026 - 10:05 PST