R360 Cloud Hosting - QuickBooks Remote Desktop - New Website Launched! - https://r360.com
Incident Report for R360 CLOUD HOSTING
Resolved
This incident has been resolved.
Posted Jul 28, 2022 - 12:59 PDT
Monitoring
Dear R360 Cloud Hosting - QuickBooks Remote Desktop Customers,

We are officially launching our new website https://r360.com. This website is dedicated to just our R360 Cloud Hosting for QuickBooks Remote Desktops which is separate from our Invoicing and Payment Processing platform RECUR360 (https://www.recur360.com).

By separating our two product offerings into their own separate websites we hope to remove any confusion related to logins and support for each of our products.

Going forward to Authenticate on our website for QuickBooks Remote Desktops, please go to https://r360.com and click the Login button in the upper right corner. The remainder of the process will remain the same.

You can also subscribe to status updates at https://status.r360.com. You've already been auto-subscribed via your email address on file but you can add your phone # for text messaging notifications as well.

If you have any questions or concerns please go to our new website's LiveChat https://r360.com/chat.

Best Regards,

Andrew B Abrams
CEO
R360 Cloud Hosting - A Division of RECUR360 TECHNOLOGIES LLC
Posted Jul 28, 2022 - 12:06 PDT
This incident affected: R360 CLOUD HOSTING - QuickBooks Remote Desktops.